Developer configuration problem

I used Ubuntu22.04 to follow the developer 's guide to complete the process, and finally showed that the configuration was successful, but there was no ’ ogs ’ in the build / bin folder.
What is the reason?
How can I really configure success?

You need to build it after configuration. If you configured it for ninja you can build it typing ninja otherwise make. See Build for further details.

Dear joergbuchwald, thank you very much for solving my doubts. After I watched the video tutorial on the official website, I thought that cmake was the end point. After reading your answers, I continued the tutorial of the developer 's guide. However, when running the sudo cmake-preset release-petsc command on the Build configuration for MPI and PETSc module, no matter how I proceed, there is an error when loading the package at the picture.
How should I solve this problem ?

You need to install the parallel version of hdf5.
I guess for ubuntu it is probably this package:

Dear joergbuchwald, I have been busy with the project assigned by the tutor during this period of time, and after your professional guidance, I did complete the steps of the guide smoothly, I am very grateful.
However, when I follow the tutorial - advancing glacier, I use the file provided by the tutorial. After reaching the step of post-processing paraview software, there are only two attributes of sigma and displacement in the point / unit / column array state under the output attribute, which is obviously inconsistent with the 10 attributes in the video tutorial. Later, I operated on the Wellbore Heat Transport-EUBHE example under Benchmarks, and the same problem occurred: the output attributes and the variables finally presented on the coordinate axis are not so many. Is this related to my configuration process, or what is the problem?
The comparison between my paraview and the tutorial paraview is attached below.

This might be due to a recent change in OGS.
We now default to writing less output by default:
If any output is requested explicitely, only that is written. In the past the default was to output much more/all available data by default.
If you empty the <time_loop/output/variables> setting in the prj files you should see much more output.
I hope that solves the problem.

Best regards,