I can't use msh2vtu

Hello friends
I can’t use msh2vtu, I get an error no matter what I do. Can anyone help me, what steps should I take?
I think I have a problem installing it
Because at first I was installing it locally, but I realized that it is not necessary to install it at all, but it is part of ogstools, and it is enough to install it.
Thank you for your help

Hello Mohammad,

would you let us know what error you get?

I ran the ogs example and it was as follows:
First, I go to the path of msh2vtu, then I run the command python msh2vtu.py --ogs --rdcd geolayers_2d.msh.
But I am facing the following error:
Newer version of Meshio than supported. Backward compatibility may be missing!

Original mesh (read)
1389 points in 3 dimensions; cells: 256 lines, 2520 triangles; point_data=[‘gmsh:dim_tags’]; cell_data=[‘gmsh:physical’, ‘gmsh:geometrical’]; cell_sets=[‘Left’, ‘Bottom’, ‘Right’, ‘Top’, ‘SedimentLayer1’, ‘SedimentLayer2’, ‘SedimentLayer3’, ‘RockBed’, ‘gmsh:bounding_entities’]

Info: VTU format cannot write cell_sets. Converting them to cell_data…
Traceback (most recent call last):
File “C:\Users\user\OneDrive\Desktop\msh2vtu\msh2vtu\msh2vtu.py”, line 202, in
meshio.write(output_basename + “_original.vtu”, mesh, binary=not args.ascii)
File “C:\Users\user\AppData\Local\Programs\Python\Python311\Lib\site-packages\meshio_helpers.py”, line 188, in write
return writer(filename, mesh, **kwargs)
File “C:\Users\user\AppData\Local\Programs\Python\Python311\Lib\site-packages\meshio\vtu_vtu.py”, line 644, in write
File “C:\Users\user\AppData\Local\Programs\Python\Python311\Lib\site-packages\meshio_mesh.py”, line 328, in cell_sets_to_data
arr[cc] = i
IndexError: index 13 is out of bounds for axis 0 with size 10

Difficult to say something based on the error. It is originated in meshio, so maybe this is related to your installation problems in the other thread.

Without any data and ways to reproduce the behaviour, unfortunately, not much can be done.

– d