IPREEQC database issue

Good day. I have an issue to simulate a reactive transport with a custom made database file.

I would like to run the simulation in a 1D and 2D (homogeneous and heterogeneous case). When i run the simulation I get results without any problem in 1D case but doesnt work in 2D case.

I think the problem is with Reaction (R3) in the 2D case, if i remove this the simulation works smooth but I need it as part of my results, can some one help me with this?
Harish RSimulations.zip (6.7 KB)

Dear Harish,

I will have a look to your inputs files
Best wishes

I checked if the problem was the database created… and this is not the case.

I think the problem is the Stoichiometry you have defined for your kinetic “R3”. The kinetic law only contain “carbonate” in the formula. But to form “CalciumCarbonate” you need both “calcium” and “carbonate” (according to the stoichiometry you have defined in the database). I do not know the conditions of your model, but “calcium” concentration in the aqueous solution should be defined (even if it is a very small number).

I hope this helps you.
Best wishes

Hello Dr. Vanessa, Thank you for your reply.
I used Carbonate in the stoichiometry to run the simulation, which obviously means no calcium is consumed but this is not the ideal calculation i want.

I am unable to run my simulation if I have the condition as Calcium 1 and Carbonate 1. I dont receive any error info either.

also if I remove Carbonate from the stoichiometry and use the .dat file linkage of calcium and carbonate to R3 it still doesnt work.

Harish R

Hi Harish,

I don’t know exactly what error are you getting, but I noticed in your input files that the tolerances for the global process coupling may be limiting your 2D simulation. You may get results for the 1D case with those, but you may want to increase the tolerances a bit for the 2D model.

Best regards,

Hello Jaime,

Thanks for your reply, I increased the tolerance to 1e7 in global coupling and also for convergence criteria and I am still unable to get results. I have attached my simulation folder with this mail for your glance. Thank you.

All files.zip (7.1 MB)

I think you should set the tolerances to 1e-7 instead of 1e7! Ok but maybe that’s not the issue. Other thing you might try is to set a very small initial amount (1e-10) to R1, R2 and R7, but I don’t know if you can do this with your specific setup…

Thank you again Jaime, sadly this didnt make any significant difference either.

check the defintion of the <chemical_system> keyword, it seems that you do not have a mesh specified there.
Also, I recommend that you execute ogs in a terminal instead, in your working directory:

./ogs.exe gs5_H.prj

Hello Jaime, thanks i use ogs version 6.2.1 in which mesh need not be specified in the older version.

I am sorry I didnt understand the second part of your reply. So should i rename my project file as ogs.exe gs5_H.prj ?

I see. I meant that sometimes it is easier to catch an error (like the one I mentioned) when you execute OGS from the command line. Just thought I mentioned it in case it helps, but it seems that in your case there are no problems with the input file (I executed with your provided OGS version). Perhaps you would like to try to solve your model in a more recent version (6.3.3) if possible.

BTW, your 2D mesh is pretty large (10,000 cells), so you may have to wait a long time between time steps for Phreeqc to complete calculations. Consider lowering the resolution/domain size, if it suits your modeling setup.

It takes 7-8 minutes for each time step usually. I want to ask if you were able to generate output from my input file? Yes it works if I have the carbonate stoichiometry as 1 but the actual solution I need is carbonate 1 calcium 1 as stoichiometry for kinetic R3.

I also tried OGS 6.3.3 and it’s pretty slow on larger domains.

No, I wasn’t able to generate output with your provided input files either.