Homepage Books Releases Docs Discourse

OGS5 and PETSc

Dear OGS developers,

although OGS5 is at the end of its development (or am I wrong?) may you update the page

https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2

adding the information that to compile with PETSc not only the OGS_CONFIG must be changed, but also the OGS_LSOLVER (see https://github.com/ufz/ogs5/pull/18 ) ?

It is a trivial problem. But only after you solve it.

Another question: what is the latest supported version of PETSc by OGS 5.7.1?

Thanks.

Luca Urpi

+41446338372

Swiss Seismological Service

ETH Zürich, NO H 62

Sonneggstrasse 5

8092 Zürich

Hi Luca,

Setting -DOGS_CONFIG=PESC in CMake should be enough. OGS_LSOLVER is automatically set during cmake.

Regarding the PETSc version, I think current OGS5 supports till 3.5.
(Wenqing, please correct me if I'm wrong).

Best,
Nori

···

On 05/22/2017 11:25 PM, Luca Urpi wrote:

Dear OGS developers,

although OGS5 is at the end of its development (or am I wrong?) may you update the page

https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2

adding the information that to compile with PETSc not only the OGS_CONFIG must be changed, but also the OGS_LSOLVER (see https://github.com/ufz/ogs5/pull/18 ) ?

It is a trivial problem. But only after you solve it.

Another question: what is the latest supported version of PETSc by OGS 5.7.1?

Thanks.

Luca Urpi
+41446338372

Swiss Seismological Service
ETH Zürich, NO H 62
Sonneggstrasse 5
8092 Zürich

--
You received this message because you are subscribed to the Google Groups "ogs-devs" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ogs-devs+unsubscribe@googlegroups.com <mailto:ogs-devs+unsubscribe@googlegroups.com>.
For more options, visit https://groups.google.com/d/optout.

I tried again, at least on the machine I am using (Fedora 25, cmake 3.8.0), it does not set automatically with cmake or with cmake-gui (also, it does not work with MPI).

···

2017-05-23 23:20 GMT+02:00 Norihiro Watanabe norihiro.watanabe@aist.go.jp:

Hi Luca,

Setting -DOGS_CONFIG=PESC in CMake should be enough. OGS_LSOLVER is automatically set during cmake.

Regarding the PETSc version, I think current OGS5 supports till 3.5.

(Wenqing, please correct me if I’m wrong).

Best,

Nori

On 05/22/2017 11:25 PM, Luca Urpi wrote:

Dear OGS developers,

although OGS5 is at the end of its development (or am I wrong?) may you update the page

https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2

adding the information that to compile with PETSc not only the OGS_CONFIG must be changed, but also the OGS_LSOLVER (see https://github.com/ufz/ogs5/pull/18 ) ?

It is a trivial problem. But only after you solve it.

Another question: what is the latest supported version of PETSc by OGS 5.7.1?

Thanks.

Luca Urpi

+41446338372

Swiss Seismological Service

ETH Zürich, NO H 62

Sonneggstrasse 5

8092 Zürich

You received this message because you are subscribed to the Google Groups “ogs-devs” group.

To unsubscribe from this group and stop receiving emails from it, send an email to ogs-devs+unsubscribe@googlegroups.com mailto:ogs-devs+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to the Google Groups “ogs-devs” group.

To unsubscribe from this group and stop receiving emails from it, send an email to ogs-devs+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

i see. it’s working on the test machine at ufz. i will check it later when i have time. thanks for reporting the problem.

n

···

From: ogs-devs@googlegroups.com ogs-devs@googlegroups.com on behalf of Luca Urpi luca.urpi@gmail.com

Sent: Wednesday, May 24, 2017 6:41:05 PM

To: ogs-devs@googlegroups.com

Subject: Re: OGS5 and PETSc

I tried again, at least on the machine I am using (Fedora 25, cmake 3.8.0), it does not set automatically with cmake or with cmake-gui (also, it does not work with MPI).

2017-05-23 23:20 GMT+02:00 Norihiro Watanabe
norihiro.watanabe@aist.go.jp:

Hi Luca,

Setting -DOGS_CONFIG=PESC in CMake should be enough. OGS_LSOLVER is automatically set during cmake.

Regarding the PETSc version, I think current OGS5 supports till 3.5.

(Wenqing, please correct me if I’m wrong).

Best,

Nori

On 05/22/2017 11:25 PM, Luca Urpi wrote:

Dear OGS developers,

although OGS5 is at the end of its development (or am I wrong?) may you update the page

https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2

adding the information that to compile with PETSc not only the OGS_CONFIG must be changed, but also the OGS_LSOLVER (see https://github.com/ufz/ogs5/pull/18 ) ?

It is a trivial problem. But only after you solve it.

Another question: what is the latest supported version of PETSc by OGS 5.7.1?

Thanks.

Luca Urpi

+41446338372

Swiss Seismological Service

ETH Zürich, NO H 62

Sonneggstrasse 5

8092 Zürich

You received this message because you are subscribed to the Google Groups “ogs-devs” group.

To unsubscribe from this group and stop receiving emails from it, send an email to ogs-devs+unsubscribe@googlegroups.com mailto:ogs-devs+unsubscribe@googlegroups.com.

For more options, visit
https://groups.google.com/d/optout
.

You received this message because you are subscribed to the Google Groups “ogs-devs” group.

To unsubscribe from this group and stop receiving emails from it, send an email to ogs-devs+unsubscribe@googlegroups.com.

For more options, visit
https://groups.google.com/d/optout
.

You received this message because you are subscribed to the Google Groups “ogs-devs” group.

To unsubscribe from this group and stop receiving emails from it, send an email to ogs-devs+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

Hi,

sorry there was a typo. it should be -DOGS_CONFIG=PETC. I tested on my machine with the following command and it is also working here.

cmake ../sources/ -DOGS_CONFIG=PETSC -DPESC_DIR=/opt/petsc/petsc-3.5.4/ -DPETSC_ARCH=gcc-release

maybe you need to remove the build dir once and test it again.

n

···

On 05/24/2017 06:41 PM, Luca Urpi wrote:

I tried again, at least on the machine I am using (Fedora 25, cmake 3.8.0), it does not set automatically with cmake or with cmake-gui (also, it does not work with MPI).

2017-05-23 23:20 GMT+02:00 Norihiro Watanabe <norihiro.watanabe@aist.go.jp <mailto:norihiro.watanabe@aist.go.jp>>:

    Hi Luca,

    Setting -DOGS_CONFIG=PESC in CMake should be enough. OGS_LSOLVER is
    automatically set during cmake.

    Regarding the PETSc version, I think current OGS5 supports till 3.5.
    (Wenqing, please correct me if I'm wrong).

    Best,
    Nori

    On 05/22/2017 11:25 PM, Luca Urpi wrote:

        Dear OGS developers,

        although OGS5 is at the end of its development (or am I wrong?)
        may you update the page

        https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2
        <https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2>

        adding the information that to compile with PETSc not only the
        OGS_CONFIG must be changed, but also the OGS_LSOLVER (see
        https://github.com/ufz/ogs5/pull/18
        <https://github.com/ufz/ogs5/pull/18> ) ?

        It is a trivial problem. But only after you solve it.

        Another question: what is the latest supported version of PETSc
        by OGS 5.7.1?

        Thanks.

        Luca Urpi
        +41446338372 <tel:%2B41446338372>

        Swiss Seismological Service
        ETH Zürich, NO H 62
        Sonneggstrasse 5
        8092 Zürich

        -- You received this message because you are subscribed to the
        Google Groups "ogs-devs" group.
        To unsubscribe from this group and stop receiving emails from
        it, send an email to ogs-devs+unsubscribe@googlegroups.com
        <mailto:ogs-devs%2Bunsubscribe@googlegroups.com>
        <mailto:ogs-devs+unsubscribe@googlegroups.com
        <mailto:ogs-devs%2Bunsubscribe@googlegroups.com>>.
        For more options, visit https://groups.google.com/d/optout
        <https://groups.google.com/d/optout>.

    -- You received this message because you are subscribed to the Google
    Groups "ogs-devs" group.
    To unsubscribe from this group and stop receiving emails from it,
    send an email to ogs-devs+unsubscribe@googlegroups.com
    <mailto:ogs-devs%2Bunsubscribe@googlegroups.com>.
    For more options, visit https://groups.google.com/d/optout
    <https://groups.google.com/d/optout>.

--
You received this message because you are subscribed to the Google Groups "ogs-devs" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ogs-devs+unsubscribe@googlegroups.com <mailto:ogs-devs+unsubscribe@googlegroups.com>.
For more options, visit https://groups.google.com/d/optout.

Alright, yes the problem is with reusing the build dir.
If cmake is run for the first time, then it sets OGS_LSOLVER to the corresponding OGS_CONFIG: if no value is given it defaults to RF. Then if the same build folder is used afterwards, with different OGS_CONFIG, the OGS_LSOLVER needs to be set manually.

With cmake-gui, OGS_LSOLVER must be set manually, since it is set to RF with the first “configure”.
However, if OGS_LSOLVER is set manually to DEFAULT, then it is updated automatically with the right value according to OGS_CONFIG, running “configure” for the second time.
Maybe there is an error and OGS_LSOLVER should be set to DEFAULT by the first “configure”? I am not very practical with cmake definitions and set-up.

Thanks for your patience.

Luca

···

2017-05-26 0:11 GMT+02:00 Norihiro Watanabe norihiro.watanabe@aist.go.jp:

I tried again, at least on the machine I am using (Fedora 25, cmake 3.8.0), it does not set automatically with cmake or with cmake-gui (also, it does not work with MPI).

2017-05-23 23:20 GMT+02:00 Norihiro Watanabe <norihiro.watanabe@aist.go.jp mailto:norihiro.watanabe@aist.go.jp>:

Hi Luca,



Setting -DOGS_CONFIG=PESC in CMake should be enough. OGS_LSOLVER is

automatically set during cmake.



Regarding the PETSc version, I think current OGS5 supports till 3.5.

(Wenqing, please correct me if I'm wrong).





Best,

Nori







On 05/22/2017 11:25 PM, Luca Urpi wrote:



    Dear OGS developers,



    although OGS5 is at the end of its development (or am I wrong?)

    may you update the page



    [https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2](https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2)

    <[https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2](https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2)>



    adding the information that to compile with PETSc not only the

    OGS_CONFIG must be changed, but also the OGS_LSOLVER (see

    [https://github.com/ufz/ogs5/pull/18](https://github.com/ufz/ogs5/pull/18)

    <[https://github.com/ufz/ogs5/pull/18](https://github.com/ufz/ogs5/pull/18)> ) ?



    It is a trivial problem. But only after you solve it.



    Another question: what is the latest supported version of PETSc

    by OGS 5.7.1?



    Thanks.



    Luca Urpi

    +41446338372 <tel:%2B41446338372>



    Swiss Seismological Service

    ETH Zürich, NO H 62

    Sonneggstrasse 5

    8092 Zürich





    --         You received this message because you are subscribed to the

    Google Groups "ogs-devs" group.

    To unsubscribe from this group and stop receiving emails from

    it, send an email to ogs-devs+unsubscribe@googlegroups.com

    <mailto:ogs-devs%2Bunsubscribe@googlegroups.com>

    <mailto:ogs-devs+unsubscribe@googlegroups.com

    <mailto:ogs-devs%2Bunsubscribe@googlegroups.com>>.

    For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout)

    <[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>.





--     You received this message because you are subscribed to the Google

Groups "ogs-devs" group.

To unsubscribe from this group and stop receiving emails from it,

send an email to ogs-devs+unsubscribe@googlegroups.com

<mailto:ogs-devs%2Bunsubscribe@googlegroups.com>.

For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout)

<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>.

You received this message because you are subscribed to the Google Groups “ogs-devs” group.

To unsubscribe from this group and stop receiving emails from it, send an email to ogs-devs+unsubscribe@googlegroups.com mailto:ogs-devs+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to the Google Groups “ogs-devs” group.

To unsubscribe from this group and stop receiving emails from it, send an email to ogs-devs+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

Hi,

sorry there was a typo. it should be -DOGS_CONFIG=PETC. I tested on my machine with the following command and it is also working here.

cmake …/sources/ -DOGS_CONFIG=PETSC -DPESC_DIR=/opt/petsc/petsc-3.5.4/ -DPETSC_ARCH=gcc-release

maybe you need to remove the build dir once and test it again.

n

On 05/24/2017 06:41 PM, Luca Urpi wrote:

many thanks for reporting the details. The problem should be fixed in #81 (https://github.com/ufz/ogs5/pull/81).

best,
nori

···

On 05/26/2017 08:39 PM, Luca Urpi wrote:

Alright, yes the problem is with reusing the build dir.
If cmake is run for the first time, then it sets OGS_LSOLVER to the corresponding OGS_CONFIG: if no value is given it defaults to RF. Then if the same build folder is used afterwards, with different OGS_CONFIG, the OGS_LSOLVER needs to be set manually.

With cmake-gui, OGS_LSOLVER must be set manually, since it is set to RF with the first "configure".
However, if OGS_LSOLVER is set manually to DEFAULT, then it is updated automatically with the right value according to OGS_CONFIG, running "configure" for the second time.
Maybe there is an error and OGS_LSOLVER should be set to DEFAULT by the first "configure"? I am not very practical with cmake definitions and set-up.

Thanks for your patience.

Luca

2017-05-26 0:11 GMT+02:00 Norihiro Watanabe <norihiro.watanabe@aist.go.jp <mailto:norihiro.watanabe@aist.go.jp>>:

    Hi,

    sorry there was a typo. it should be -DOGS_CONFIG=PETC. I tested on
    my machine with the following command and it is also working here.

    cmake ../sources/ -DOGS_CONFIG=PETSC
    -DPESC_DIR=/opt/petsc/petsc-3.5.4/ -DPETSC_ARCH=gcc-release

    maybe you need to remove the build dir once and test it again.

    n

    On 05/24/2017 06:41 PM, Luca Urpi wrote:

        I tried again, at least on the machine I am using (Fedora 25,
        cmake 3.8.0), it does not set automatically with cmake or with
        cmake-gui (also, it does not work with MPI).

        2017-05-23 23:20 GMT+02:00 Norihiro Watanabe
        <norihiro.watanabe@aist.go.jp
        <mailto:norihiro.watanabe@aist.go.jp>
        <mailto:norihiro.watanabe@aist.go.jp
        <mailto:norihiro.watanabe@aist.go.jp>>>:

             Hi Luca,

             Setting -DOGS_CONFIG=PESC in CMake should be enough.
        OGS_LSOLVER is
             automatically set during cmake.

             Regarding the PETSc version, I think current OGS5 supports
        till 3.5.
             (Wenqing, please correct me if I'm wrong).

             Best,
             Nori

             On 05/22/2017 11:25 PM, Luca Urpi wrote:

                 Dear OGS developers,

                 although OGS5 is at the end of its development (or am I
        wrong?)
                 may you update the page

        https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2
        <https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2>
                        <https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2
        <https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2>>

                 adding the information that to compile with PETSc not
        only the
                 OGS_CONFIG must be changed, but also the OGS_LSOLVER (see
        https://github.com/ufz/ogs5/pull/18
        <https://github.com/ufz/ogs5/pull/18>
                 <https://github.com/ufz/ogs5/pull/18
        <https://github.com/ufz/ogs5/pull/18>> ) ?

                 It is a trivial problem. But only after you solve it.

                 Another question: what is the latest supported version
        of PETSc
                 by OGS 5.7.1?

                 Thanks.

                 Luca Urpi
        +41446338372 <tel:%2B41446338372> <tel:%2B41446338372>

                 Swiss Seismological Service
                 ETH Zürich, NO H 62
                 Sonneggstrasse 5
                 8092 Zürich

                 -- You received this message because you are
        subscribed to the
                 Google Groups "ogs-devs" group.
                 To unsubscribe from this group and stop receiving
        emails from
                 it, send an email to
        ogs-devs+unsubscribe@googlegroups.com
        <mailto:ogs-devs%2Bunsubscribe@googlegroups.com>
                 <mailto:ogs-devs%2Bunsubscribe@googlegroups.com
        <mailto:ogs-devs%252Bunsubscribe@googlegroups.com>>
                 <mailto:ogs-devs+unsubscribe@googlegroups.com
        <mailto:ogs-devs%2Bunsubscribe@googlegroups.com>
                 <mailto:ogs-devs%2Bunsubscribe@googlegroups.com
        <mailto:ogs-devs%252Bunsubscribe@googlegroups.com>>>.
                 For more options, visit
        https://groups.google.com/d/optout
        <https://groups.google.com/d/optout>
                 <https://groups.google.com/d/optout
        <https://groups.google.com/d/optout>>.

             -- You received this message because you are subscribed
        to the Google
             Groups "ogs-devs" group.
             To unsubscribe from this group and stop receiving emails
        from it,
             send an email to ogs-devs+unsubscribe@googlegroups.com
        <mailto:ogs-devs%2Bunsubscribe@googlegroups.com>
             <mailto:ogs-devs%2Bunsubscribe@googlegroups.com
        <mailto:ogs-devs%252Bunsubscribe@googlegroups.com>>.
             For more options, visit https://groups.google.com/d/optout
        <https://groups.google.com/d/optout>
             <https://groups.google.com/d/optout
        <https://groups.google.com/d/optout>>.

        -- You received this message because you are subscribed to the
        Google Groups "ogs-devs" group.
        To unsubscribe from this group and stop receiving emails from
        it, send an email to ogs-devs+unsubscribe@googlegroups.com
        <mailto:ogs-devs%2Bunsubscribe@googlegroups.com>
        <mailto:ogs-devs+unsubscribe@googlegroups.com
        <mailto:ogs-devs%2Bunsubscribe@googlegroups.com>>.
        For more options, visit https://groups.google.com/d/optout
        <https://groups.google.com/d/optout>.

    -- You received this message because you are subscribed to the Google
    Groups "ogs-devs" group.
    To unsubscribe from this group and stop receiving emails from it,
    send an email to ogs-devs+unsubscribe@googlegroups.com
    <mailto:ogs-devs%2Bunsubscribe@googlegroups.com>.
    For more options, visit https://groups.google.com/d/optout
    <https://groups.google.com/d/optout>.

--
You received this message because you are subscribed to the Google Groups "ogs-devs" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ogs-devs+unsubscribe@googlegroups.com <mailto:ogs-devs+unsubscribe@googlegroups.com>.
For more options, visit https://groups.google.com/d/optout.

Hello Nori,

I have followed your latest patch just merged on CentOS 7. The compilation works just fine with the configuration below. However, when I tried it with KueperProblem-PS benchmark, it works great with the following.

[nbeyond@cc KueperProblem-PS]$ mpirun -f mfile -np 3 $ogs_petsc kueper

My question from here is: How can I prepare kueper_partitioned_nodes_3.msh, kueper_partitioned_elems_3.msh, and kueper_partitioned_cfg3.msh? I guess those should come from

partmesh --ogs2metis kueper

mpmetis kueper.mesh

partmesh --metis2ogs -np 3 -n kueper

I do not see how to get the last one ( kueper_partitioned_cfg3.msh). I appreciate any help on this.

One more question, please. Would the latest ogs 5 with the patch work with HT problems on sequential mode if the configuration files are prepared just as I talked? This is extremely important because it is all about scale-up of applications to multi-million nodes. Thanks in advance.

Best regards,

···

On Monday, May 29, 2017 at 7:28:03 AM UTC+9, Norihiro Watanabe wrote:

many thanks for reporting the details. The problem should be fixed in
#81 (https://github.com/ufz/ogs5/pull/81).

best,
nori

On 05/26/2017 08:39 PM, Luca Urpi wrote:

Alright, yes the problem is with reusing the build dir.
If cmake is run for the first time, then it sets OGS_LSOLVER to the
corresponding OGS_CONFIG: if no value is given it defaults to RF. Then
if the same build folder is used afterwards, with different OGS_CONFIG,
the OGS_LSOLVER needs to be set manually.

With cmake-gui, OGS_LSOLVER must be set manually, since it is set to RF
with the first “configure”.
However, if OGS_LSOLVER is set manually to DEFAULT, then it is updated
automatically with the right value according to OGS_CONFIG, running
“configure” for the second time.
Maybe there is an error and OGS_LSOLVER should be set to DEFAULT by the
first “configure”? I am not very practical with cmake definitions and
set-up.

Thanks for your patience.

Luca

2017-05-26 0:11 GMT+02:00 Norihiro Watanabe
<norihiro…@aist.go.jp mailto:norihiro...@aist.go.jp>:

Hi,

sorry there was a typo. it should be -DOGS_CONFIG=PETC. I tested on
my machine with the following command and it is also working here.

cmake ../sources/ -DOGS_CONFIG=PETSC
-DPESC_DIR=/opt/petsc/petsc-3.5.4/ -DPETSC_ARCH=gcc-release

maybe you need to remove the build dir once and test it again.

n


On 05/24/2017 06:41 PM, Luca Urpi wrote:

    I tried again, at least on the machine I am using (Fedora 25,
    cmake 3.8.0), it does not set automatically with cmake or with
    cmake-gui (also, it does not work with MPI).


    2017-05-23 23:20 GMT+02:00 Norihiro Watanabe
    <norihiro...@aist.go.jp
    <mailto:norihiro...@aist.go.jp>
    <mailto:norihiro...@aist.go.jp
    <mailto:norihiro...@aist.go.jp>>>:

         Hi Luca,

         Setting -DOGS_CONFIG=PESC in CMake should be enough.
    OGS_LSOLVER is
         automatically set during cmake.

         Regarding the PETSc version, I think current OGS5 supports
    till 3.5.
         (Wenqing, please correct me if I'm wrong).


         Best,
         Nori



         On 05/22/2017 11:25 PM, Luca Urpi wrote:

             Dear OGS developers,

             although OGS5 is at the end of its development (or am I
    wrong?)
             may you update the page

    [https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2](https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2)
    <[https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2](https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2)>
           
    <[https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2](https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2)
    <[https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2](https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2)>>

             adding the information that to compile with PETSc not
    only the
             OGS_CONFIG must be changed, but also the OGS_LSOLVER (see
    [https://github.com/ufz/ogs5/pull/18](https://github.com/ufz/ogs5/pull/18)
    <[https://github.com/ufz/ogs5/pull/18](https://github.com/ufz/ogs5/pull/18)>
             <[https://github.com/ufz/ogs5/pull/18](https://github.com/ufz/ogs5/pull/18)
    <[https://github.com/ufz/ogs5/pull/18](https://github.com/ufz/ogs5/pull/18)>> ) ?

             It is a trivial problem. But only after you solve it.

             Another question: what is the latest supported version
    of PETSc
             by OGS 5.7.1?

             Thanks.

             Luca Urpi
    +41446338372 <tel:%2B41446338372> <tel:%2B41446338372>

             Swiss Seismological Service
             ETH Zürich, NO H 62
             Sonneggstrasse 5
             8092 Zürich


             --         You received this message because you are
    subscribed to the
             Google Groups "ogs-devs" group.
             To unsubscribe from this group and stop receiving
    emails from
             it, send an email to
    ogs-devs+u...@googlegroups.com
    <mailto:ogs-devs%2Bunsubscribe@googlegroups.com>
             <mailto:ogs-devs%2Bunsubscribe@googlegroups.com
    <mailto:ogs-devs%252Bunsubscribe@googlegroups.com>>
             <mailto:ogs-devs+u...@googlegroups.com
    <mailto:ogs-devs%2Bunsubscribe@googlegroups.com>
             <mailto:ogs-devs%2Bunsubscribe@googlegroups.com
    <mailto:ogs-devs%252Bunsubscribe@googlegroups.com>>>.
             For more options, visit
    [https://groups.google.com/d/optout](https://groups.google.com/d/optout)
    <[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>
             <[https://groups.google.com/d/optout](https://groups.google.com/d/optout)
    <[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>>.


         --     You received this message because you are subscribed
    to the Google
         Groups "ogs-devs" group.
         To unsubscribe from this group and stop receiving emails
    from it,
         send an email to ogs-devs+u...@googlegroups.com
    <mailto:ogs-devs%2Bunsubscribe@googlegroups.com>
         <mailto:ogs-devs%2Bunsubscribe@googlegroups.com
    <mailto:ogs-devs%252Bunsubscribe@googlegroups.com>>.
         For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout)
    <[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>
         <[https://groups.google.com/d/optout](https://groups.google.com/d/optout)
    <[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>>.


    --
    You received this message because you are subscribed to the
    Google Groups "ogs-devs" group.
    To unsubscribe from this group and stop receiving emails from
    it, send an email to ogs-devs+u...@googlegroups.com
    <mailto:ogs-devs%2Bunsubscribe@googlegroups.com>
    <mailto:ogs-devs+u...@googlegroups.com
    <mailto:ogs-devs%2Bunsubscribe@googlegroups.com>>.
    For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout)
    <[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>.


--
You received this message because you are subscribed to the Google
Groups "ogs-devs" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to ogs-devs+u...@googlegroups.com
<mailto:ogs-devs%2Bunsubscribe@googlegroups.com>.
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout)
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>.


You received this message because you are subscribed to the Google
Groups “ogs-devs” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to ogs-devs+u...@googlegroups.com

mailto:ogs-devs+u...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hi,

Hello Nori,

I have followed your latest patch just merged on CentOS 7. The compilation works just fine with the configuration below. However, when I tried it with KueperProblem-PS benchmark, it works great with the following.

[nbeyond@cc KueperProblem-PS]$ mpirun -f mfile -np 3 $ogs_petsc kueper

My question from here is: How can I prepare kueper_partitioned_nodes_3.msh, kueper_partitioned_elems_3.msh, and kueper_partitioned_cfg3.msh? I guess those should come from

    partmesh --ogs2metis kueper
    mpmetis kueper.mesh
    partmesh --metis2ogs -np 3 -n kueper

I do not see how to get the last one ( *kueper_partitioned_cfg3.msh*). I appreciate any help on this.

Have you tested with the latest partmesh available from https://github.com/ufz/mesh_partition? I think Wenqing has made some changes and it generates _cfg*.

One more question, please. Would the latest ogs 5 with the patch work with HT problems on sequential mode if the configuration files are prepared just as I talked? This is extremely important because it is all about scale-up of applications to multi-million nodes. Thanks in advance.

What do you mean sequential mode? sequential coupling? HT processes should also work with petsc.

n

···

On 05/31/2017 02:45 PM, Chan-Hee Park wrote:

Best regards,

On Monday, May 29, 2017 at 7:28:03 AM UTC+9, Norihiro Watanabe wrote:

    many thanks for reporting the details. The problem should be fixed in
    #81 (https://github.com/ufz/ogs5/pull/81
    <https://github.com/ufz/ogs5/pull/81>).

    best,
    nori

    On 05/26/2017 08:39 PM, Luca Urpi wrote:
     > Alright, yes the problem is with reusing the build dir.
     > If cmake is run for the first time, then it sets OGS_LSOLVER to the
     > corresponding OGS_CONFIG: if no value is given it defaults to RF.
    Then
     > if the same build folder is used afterwards, with different
    OGS_CONFIG,
     > the OGS_LSOLVER needs to be set manually.
     >
     > With cmake-gui, OGS_LSOLVER must be set manually, since it is set
    to RF
     > with the first "configure".
     > However, if OGS_LSOLVER is set manually to DEFAULT, then it is
    updated
     > automatically with the right value according to OGS_CONFIG, running
     > "configure" for the second time.
     > Maybe there is an error and OGS_LSOLVER should be set to DEFAULT
    by the
     > first "configure"? I am not very practical with cmake definitions
    and
     > set-up.
     >
     > Thanks for your patience.
     >
     > Luca
     >
     > 2017-05-26 0:11 GMT+02:00 Norihiro Watanabe
     > <norihiro...@aist.go.jp <javascript:>
    <mailto:norihiro...@aist.go.jp <javascript:>>>:
     >
     > Hi,
     >
     > sorry there was a typo. it should be -DOGS_CONFIG=PETC. I
    tested on
     > my machine with the following command and it is also working
    here.
     >
     > cmake ../sources/ -DOGS_CONFIG=PETSC
     > -DPESC_DIR=/opt/petsc/petsc-3.5.4/ -DPETSC_ARCH=gcc-release
     >
     > maybe you need to remove the build dir once and test it again.
     >
     > n
     >
     > On 05/24/2017 06:41 PM, Luca Urpi wrote:
     >
     > I tried again, at least on the machine I am using (Fedora
    25,
     > cmake 3.8.0), it does not set automatically with cmake or
    with
     > cmake-gui (also, it does not work with MPI).
     >
     > 2017-05-23 23:20 GMT+02:00 Norihiro Watanabe
     > <norihiro...@aist.go.jp <javascript:>
     > <mailto:norihiro...@aist.go.jp <javascript:>>
     > <mailto:norihiro...@aist.go.jp <javascript:>
     > <mailto:norihiro...@aist.go.jp <javascript:>>>>:
     >
     > Hi Luca,
     >
     > Setting -DOGS_CONFIG=PESC in CMake should be enough.
     > OGS_LSOLVER is
     > automatically set during cmake.
     >
     > Regarding the PETSc version, I think current OGS5
    supports
     > till 3.5.
     > (Wenqing, please correct me if I'm wrong).
     >
     > Best,
     > Nori
     >
     > On 05/22/2017 11:25 PM, Luca Urpi wrote:
     >
     > Dear OGS developers,
     >
     > although OGS5 is at the end of its development
    (or am I
     > wrong?)
     > may you update the page
     >
    https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2
    <https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2>

     > <https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2
    <https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2>>

     >
     > <https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2
    <https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2>

     > <https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2
    <https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2>>>

     >
     > adding the information that to compile with
    PETSc not
     > only the
     > OGS_CONFIG must be changed, but also the
    OGS_LSOLVER (see
     > https://github.com/ufz/ogs5/pull/18
    <https://github.com/ufz/ogs5/pull/18>
     > <https://github.com/ufz/ogs5/pull/18
    <https://github.com/ufz/ogs5/pull/18>>
     > <https://github.com/ufz/ogs5/pull/18
    <https://github.com/ufz/ogs5/pull/18>
     > <https://github.com/ufz/ogs5/pull/18
    <https://github.com/ufz/ogs5/pull/18>>> ) ?
     >
     > It is a trivial problem. But only after you
    solve it.
     >
     > Another question: what is the latest supported
    version
     > of PETSc
     > by OGS 5.7.1?
     >
     > Thanks.
     >
     > Luca Urpi
     > +41446338372 <tel:%2B41446338372> <tel:%2B41446338372>
     >
     > Swiss Seismological Service
     > ETH Zürich, NO H 62
     > Sonneggstrasse 5
     > 8092 Zürich
     >
     > -- You received this message because you
    are
     > subscribed to the
     > Google Groups "ogs-devs" group.
     > To unsubscribe from this group and stop receiving
     > emails from
     > it, send an email to
     > ogs-devs+u...@googlegroups.com <javascript:>
     > <mailto:ogs-devs%2Bunsubscribe@googlegroups.com
    <javascript:>>
     > <mailto:ogs-devs%2Bunsubscribe@googlegroups.com
    <javascript:>
     > <mailto:ogs-devs%252Bunsubscribe@googlegroups.com
    <javascript:>>>
     > <mailto:ogs-devs+u...@googlegroups.com
    <javascript:>
     > <mailto:ogs-devs%2Bunsubscribe@googlegroups.com
    <javascript:>>
     > <mailto:ogs-devs%2Bunsubscribe@googlegroups.com
    <javascript:>
     > <mailto:ogs-devs%252Bunsubscribe@googlegroups.com
    <javascript:>>>>.
     > For more options, visit
     > https://groups.google.com/d/optout
    <https://groups.google.com/d/optout>
     > <https://groups.google.com/d/optout
    <https://groups.google.com/d/optout>>
     > <https://groups.google.com/d/optout
    <https://groups.google.com/d/optout>
     > <https://groups.google.com/d/optout
    <https://groups.google.com/d/optout>>>.
     >
     > -- You received this message because you are
    subscribed
     > to the Google
     > Groups "ogs-devs" group.
     > To unsubscribe from this group and stop receiving
    emails
     > from it,
     > send an email to ogs-devs+u...@googlegroups.com
    <javascript:>
     > <mailto:ogs-devs%2Bunsubscribe@googlegroups.com
    <javascript:>>
     > <mailto:ogs-devs%2Bunsubscribe@googlegroups.com
    <javascript:>
     > <mailto:ogs-devs%252Bunsubscribe@googlegroups.com
    <javascript:>>>.
     > For more options, visit
    https://groups.google.com/d/optout
     > <https://groups.google.com/d/optout
    <https://groups.google.com/d/optout>>
     > <https://groups.google.com/d/optout
    <https://groups.google.com/d/optout>
     > <https://groups.google.com/d/optout
    <https://groups.google.com/d/optout>>>.
     >
     > --
     > You received this message because you are subscribed to the
     > Google Groups "ogs-devs" group.
     > To unsubscribe from this group and stop receiving emails
    from
     > it, send an email to ogs-devs+u...@googlegroups.com
    <javascript:>
     > <mailto:ogs-devs%2Bunsubscribe@googlegroups.com
    <javascript:>>
     > <mailto:ogs-devs+u...@googlegroups.com <javascript:>
     > <mailto:ogs-devs%2Bunsubscribe@googlegroups.com
    <javascript:>>>.
     > For more options, visit
    https://groups.google.com/d/optout
     > <https://groups.google.com/d/optout
    <https://groups.google.com/d/optout>>.
     >
     > --
     > You received this message because you are subscribed to the
    Google
     > Groups "ogs-devs" group.
     > To unsubscribe from this group and stop receiving emails from
    it,
     > send an email to ogs-devs+u...@googlegroups.com <javascript:>
     > <mailto:ogs-devs%2Bunsubscribe@googlegroups.com <javascript:>>.
     > For more options, visit https://groups.google.com/d/optout
    <https://groups.google.com/d/optout>
     > <https://groups.google.com/d/optout
    <https://groups.google.com/d/optout>>.
     >
     > --
     > You received this message because you are subscribed to the Google
     > Groups "ogs-devs" group.
     > To unsubscribe from this group and stop receiving emails from it,
    send
     > an email to ogs-devs+u...@googlegroups.com <javascript:>
     > <mailto:ogs-devs+u...@googlegroups.com <javascript:>>.
     > For more options, visit https://groups.google.com/d/optout
    <https://groups.google.com/d/optout>.

--
You received this message because you are subscribed to the Google Groups "ogs-devs" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ogs-devs+unsubscribe@googlegroups.com <mailto:ogs-devs+unsubscribe@googlegroups.com>.
For more options, visit https://groups.google.com/d/optout.

Thanks, Nori. It works with the new mesh_partition given by WW.

Now, another problem with PVD in the .out file. It doesn’t output .pvtu files to combine .vtu of each decomposed domain to have a whole domain. Does this need update Nori?

···

On Wednesday, May 31, 2017 at 2:54:41 PM UTC+9, Norihiro Watanabe wrote:

Hi,

On 05/31/2017 02:45 PM, Chan-Hee Park wrote:

Hello Nori,

I have followed your latest patch just merged on CentOS 7. The
compilation works just fine with the configuration below. However, when
I tried it with KueperProblem-PS benchmark, it works great with the
following.

[nbeyond@cc KueperProblem-PS]$ mpirun -f mfile -np 3 $ogs_petsc kueper

My question from here is: How can I
prepare kueper_partitioned_nodes_3.msh, kueper_partitioned_elems_3.msh,
and kueper_partitioned_cfg3.msh? I guess those should come from

partmesh --ogs2metis kueper
mpmetis kueper.mesh
partmesh --metis2ogs -np 3 -n kueper

I do not see how to get the last one ( kueper_partitioned_cfg3.msh). I
appreciate any help on this.

Have you tested with the latest partmesh available from
https://github.com/ufz/mesh_partition? I think Wenqing has made some
changes and it generates _cfg*.

One more question, please. Would the latest ogs 5 with the patch work
with HT problems on sequential mode if the configuration files are
prepared just as I talked? This is extremely important because it is all
about scale-up of applications to multi-million nodes. Thanks in advance.

What do you mean sequential mode? sequential coupling? HT processes
should also work with petsc.

n

Best regards,

On Monday, May 29, 2017 at 7:28:03 AM UTC+9, Norihiro Watanabe wrote:

many thanks for reporting the details. The problem should be fixed in
#81 ([https://github.com/ufz/ogs5/pull/81](https://github.com/ufz/ogs5/pull/81)
<[https://github.com/ufz/ogs5/pull/81](https://github.com/ufz/ogs5/pull/81)>).

best,
nori

On 05/26/2017 08:39 PM, Luca Urpi wrote:
 > Alright, yes the problem is with reusing the build dir.
 > If cmake is run for the first time, then it sets OGS_LSOLVER to the
 > corresponding OGS_CONFIG: if no value is given it defaults to RF.
Then
 > if the same build folder is used afterwards, with different
OGS_CONFIG,
 > the OGS_LSOLVER needs to be set manually.
 >
 > With cmake-gui, OGS_LSOLVER must be set manually, since it is set
to RF
 > with the first "configure".
 > However, if OGS_LSOLVER is set manually to DEFAULT, then it is
updated
 > automatically with the right value according to OGS_CONFIG, running
 > "configure" for the second time.
 > Maybe there is an error and OGS_LSOLVER should be set to DEFAULT
by the
 > first "configure"? I am not very practical with cmake definitions
and
 > set-up.
 >
 > Thanks for your patience.
 >
 > Luca
 >
 > 2017-05-26 0:11 GMT+02:00 Norihiro Watanabe
 > <norihiro...@aist.go.jp <javascript:>
<mailto:norihiro...@aist.go.jp <javascript:>>>:
 >
 >     Hi,
 >
 >     sorry there was a typo. it should be -DOGS_CONFIG=PETC. I
tested on
 >     my machine with the following command and it is also working
here.
 >
 >     cmake ../sources/ -DOGS_CONFIG=PETSC
 >     -DPESC_DIR=/opt/petsc/petsc-3.5.4/ -DPETSC_ARCH=gcc-release
 >
 >     maybe you need to remove the build dir once and test it again.
 >
 >     n
 >
 >
 >     On 05/24/2017 06:41 PM, Luca Urpi wrote:
 >
 >         I tried again, at least on the machine I am using (Fedora
25,
 >         cmake 3.8.0), it does not set automatically with cmake or
with
 >         cmake-gui (also, it does not work with MPI).
 >
 >
 >         2017-05-23 23:20 GMT+02:00 Norihiro Watanabe
 >         <norihiro...@aist.go.jp <javascript:>
 >         <mailto:norihiro...@aist.go.jp <javascript:>>
 >         <mailto:norihiro...@aist.go.jp <javascript:>
 >         <mailto:norihiro...@aist.go.jp <javascript:>>>>:
 >
 >              Hi Luca,
 >
 >              Setting -DOGS_CONFIG=PESC in CMake should be enough.
 >         OGS_LSOLVER is
 >              automatically set during cmake.
 >
 >              Regarding the PETSc version, I think current OGS5
supports
 >         till 3.5.
 >              (Wenqing, please correct me if I'm wrong).
 >
 >
 >              Best,
 >              Nori
 >
 >
 >
 >              On 05/22/2017 11:25 PM, Luca Urpi wrote:
 >
 >                  Dear OGS developers,
 >
 >                  although OGS5 is at the end of its development
(or am I
 >         wrong?)
 >                  may you update the page
 >
 >
[https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2](https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2)
<[https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2](https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2)>

 >        
<[https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2](https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2)
<[https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2](https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2)>>

 >
 >        
<[https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2](https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2)
<[https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2](https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2)>

 >        
<[https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2](https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2)
<[https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2](https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2)>>>

 >
 >                  adding the information that to compile with
PETSc not
 >         only the
 >                  OGS_CONFIG must be changed, but also the
OGS_LSOLVER (see
 > [https://github.com/ufz/ogs5/pull/18](https://github.com/ufz/ogs5/pull/18)
<[https://github.com/ufz/ogs5/pull/18](https://github.com/ufz/ogs5/pull/18)>
 >         <[https://github.com/ufz/ogs5/pull/18](https://github.com/ufz/ogs5/pull/18)
<[https://github.com/ufz/ogs5/pull/18](https://github.com/ufz/ogs5/pull/18)>>
 >                  <[https://github.com/ufz/ogs5/pull/18](https://github.com/ufz/ogs5/pull/18)
<[https://github.com/ufz/ogs5/pull/18](https://github.com/ufz/ogs5/pull/18)>
 >         <[https://github.com/ufz/ogs5/pull/18](https://github.com/ufz/ogs5/pull/18)
<[https://github.com/ufz/ogs5/pull/18](https://github.com/ufz/ogs5/pull/18)>>> ) ?
 >
 >                  It is a trivial problem. But only after you
solve it.
 >
 >                  Another question: what is the latest supported
version
 >         of PETSc
 >                  by OGS 5.7.1?
 >
 >                  Thanks.
 >
 >                  Luca Urpi
 >         +41446338372 <tel:%2B41446338372> <tel:%2B41446338372>
 >
 >                  Swiss Seismological Service
 >                  ETH Zürich, NO H 62
 >                  Sonneggstrasse 5
 >                  8092 Zürich
 >
 >
 >                  --         You received this message because you
are
 >         subscribed to the
 >                  Google Groups "ogs-devs" group.
 >                  To unsubscribe from this group and stop receiving
 >         emails from
 >                  it, send an email to
 > ogs-devs+u...@googlegroups.com <javascript:>
 >         <mailto:ogs-devs%2Bunsubscribe@googlegroups.com
<javascript:>>
 >                  <mailto:ogs-devs%2Bunsubscribe@googlegroups.com
<javascript:>
 >         <mailto:ogs-devs%252Bunsubscribe@googlegroups.com
<javascript:>>>
 >                  <mailto:ogs-devs+u...@googlegroups.com
<javascript:>
 >         <mailto:ogs-devs%2Bunsubscribe@googlegroups.com
<javascript:>>
 >                  <mailto:ogs-devs%2Bunsubscribe@googlegroups.com
<javascript:>
 >         <mailto:ogs-devs%252Bunsubscribe@googlegroups.com
<javascript:>>>>.
 >                  For more options, visit
 > [https://groups.google.com/d/optout](https://groups.google.com/d/optout)
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>
 >         <[https://groups.google.com/d/optout](https://groups.google.com/d/optout)
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>>
 >                  <[https://groups.google.com/d/optout](https://groups.google.com/d/optout)
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>
 >         <[https://groups.google.com/d/optout](https://groups.google.com/d/optout)
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>>>.
 >
 >
 >              --     You received this message because you are
subscribed
 >         to the Google
 >              Groups "ogs-devs" group.
 >              To unsubscribe from this group and stop receiving
emails
 >         from it,
 >              send an email to ogs-devs+u...@googlegroups.com
<javascript:>
 >         <mailto:ogs-devs%2Bunsubscribe@googlegroups.com
<javascript:>>
 >              <mailto:ogs-devs%2Bunsubscribe@googlegroups.com
<javascript:>
 >         <mailto:ogs-devs%252Bunsubscribe@googlegroups.com
<javascript:>>>.
 >              For more options, visit
[https://groups.google.com/d/optout](https://groups.google.com/d/optout) <[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>
 >         <[https://groups.google.com/d/optout](https://groups.google.com/d/optout)
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>>
 >              <[https://groups.google.com/d/optout](https://groups.google.com/d/optout)
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>
 >         <[https://groups.google.com/d/optout](https://groups.google.com/d/optout)
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>>>.
 >
 >
 >         --
 >         You received this message because you are subscribed to the
 >         Google Groups "ogs-devs" group.
 >         To unsubscribe from this group and stop receiving emails
from
 >         it, send an email to ogs-devs+u...@googlegroups.com
<javascript:>
 >         <mailto:ogs-devs%2Bunsubscribe@googlegroups.com
<javascript:>>
 >         <mailto:ogs-devs+u...@googlegroups.com <javascript:>
 >         <mailto:ogs-devs%2Bunsubscribe@googlegroups.com
<javascript:>>>.
 >         For more options, visit
[https://groups.google.com/d/optout](https://groups.google.com/d/optout) <[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>
 >         <[https://groups.google.com/d/optout](https://groups.google.com/d/optout)
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>>.
 >
 >
 >     --
 >     You received this message because you are subscribed to the
Google
 >     Groups "ogs-devs" group.
 >     To unsubscribe from this group and stop receiving emails from
it,
 >     send an email to ogs-devs+u...@googlegroups.com <javascript:>
 >     <mailto:ogs-devs%2Bunsubscribe@googlegroups.com <javascript:>>.
 >     For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout)
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>
 >     <[https://groups.google.com/d/optout](https://groups.google.com/d/optout)
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>>.
 >
 >
 > --
 > You received this message because you are subscribed to the Google
 > Groups "ogs-devs" group.
 > To unsubscribe from this group and stop receiving emails from it,
send
 > an email to ogs-devs+u...@googlegroups.com <javascript:>
 > <mailto:ogs-devs+u...@googlegroups.com <javascript:>>.
 > For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout)
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>.


You received this message because you are subscribed to the Google
Groups “ogs-devs” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to ogs-devs+u...@googlegroups.com

mailto:ogs-devs+u...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

I don't think PVTU output is supported in the official ogs5. you can use Wenqing's script

···

On 31.05.17 17:46, Chan-Hee Park wrote:

Thanks, Nori. It works with the new mesh_partition given by WW.

Now, another problem with PVD in the .out file. It doesn't output
.*pvtu* files to combine .*vtu* of each decomposed domain to have a
whole domain. Does this need update Nori?

On Wednesday, May 31, 2017 at 2:54:41 PM UTC+9, Norihiro Watanabe wrote:

    Hi,

    On 05/31/2017 02:45 PM, Chan-Hee Park wrote:
    > Hello Nori,
    >
    > I have followed your latest patch just merged on CentOS 7. The
    > compilation works just fine with the configuration below. However,
    when
    > I tried it with KueperProblem-PS benchmark, it works great with the
    > following.
    >
    > [nbeyond@cc KueperProblem-PS]$ mpirun -f mfile -np 3 $ogs_petsc
    kueper
    >
    > My question from here is: How can I
    > prepare kueper_partitioned_nodes_3.msh,
    kueper_partitioned_elems_3.msh,
    > and kueper_partitioned_cfg3.msh? I guess those should come from
    >
    > partmesh --ogs2metis kueper
    > mpmetis kueper.mesh
    > partmesh --metis2ogs -np 3 -n kueper
    >
    > I do not see how to get the last one (
    *kueper_partitioned_cfg3.msh*). I
    > appreciate any help on this.

    Have you tested with the latest partmesh available from
    https://github.com/ufz/mesh_partition
    <https://github.com/ufz/mesh_partition>? I think Wenqing has made some
    changes and it generates _cfg*.

    > One more question, please. Would the latest ogs 5 with the patch work
    > with HT problems on sequential mode if the configuration files are
    > prepared just as I talked? This is extremely important because it
    is all
    > about scale-up of applications to multi-million nodes. Thanks in
    advance.

    What do you mean sequential mode? sequential coupling? HT processes
    should also work with petsc.

    n

    >
    > Best regards,
    >
    > On Monday, May 29, 2017 at 7:28:03 AM UTC+9, Norihiro Watanabe wrote:
    >
    > many thanks for reporting the details. The problem should be
    fixed in
    > #81 (https://github.com/ufz/ogs5/pull/81
    <https://github.com/ufz/ogs5/pull/81>
    > <https://github.com/ufz/ogs5/pull/81
    <https://github.com/ufz/ogs5/pull/81>>).
    >
    > best,
    > nori
    >
    > On 05/26/2017 08:39 PM, Luca Urpi wrote:
    > > Alright, yes the problem is with reusing the build dir.
    > > If cmake is run for the first time, then it sets
    OGS_LSOLVER to the
    > > corresponding OGS_CONFIG: if no value is given it defaults
    to RF.
    > Then
    > > if the same build folder is used afterwards, with different
    > OGS_CONFIG,
    > > the OGS_LSOLVER needs to be set manually.
    > >
    > > With cmake-gui, OGS_LSOLVER must be set manually, since it
    is set
    > to RF
    > > with the first "configure".
    > > However, if OGS_LSOLVER is set manually to DEFAULT, then it is
    > updated
    > > automatically with the right value according to OGS_CONFIG,
    running
    > > "configure" for the second time.
    > > Maybe there is an error and OGS_LSOLVER should be set to
    DEFAULT
    > by the
    > > first "configure"? I am not very practical with cmake
    definitions
    > and
    > > set-up.
    > >
    > > Thanks for your patience.
    > >
    > > Luca
    > >
    > > 2017-05-26 0:11 GMT+02:00 Norihiro Watanabe
    > > <norihiro...@aist.go.jp <javascript:>
    > <mailto:norihiro...@aist.go.jp <javascript:>>>:
    > >
    > > Hi,
    > >
    > > sorry there was a typo. it should be -DOGS_CONFIG=PETC. I
    > tested on
    > > my machine with the following command and it is also
    working
    > here.
    > >
    > > cmake ../sources/ -DOGS_CONFIG=PETSC
    > > -DPESC_DIR=/opt/petsc/petsc-3.5.4/
    -DPETSC_ARCH=gcc-release
    > >
    > > maybe you need to remove the build dir once and test it
    again.
    > >
    > > n
    > >
    > > On 05/24/2017 06:41 PM, Luca Urpi wrote:
    > >
    > > I tried again, at least on the machine I am using
    (Fedora
    > 25,
    > > cmake 3.8.0), it does not set automatically with
    cmake or
    > with
    > > cmake-gui (also, it does not work with MPI).
    > >
    > > 2017-05-23 23:20 GMT+02:00 Norihiro Watanabe
    > > <norihiro...@aist.go.jp <javascript:>
    > > <mailto:norihiro...@aist.go.jp <javascript:>>
    > > <mailto:norihiro...@aist.go.jp <javascript:>
    > > <mailto:norihiro...@aist.go.jp <javascript:>>>>:
    > >
    > > Hi Luca,
    > >
    > > Setting -DOGS_CONFIG=PESC in CMake should be
    enough.
    > > OGS_LSOLVER is
    > > automatically set during cmake.
    > >
    > > Regarding the PETSc version, I think current OGS5
    > supports
    > > till 3.5.
    > > (Wenqing, please correct me if I'm wrong).
    > >
    > > Best,
    > > Nori
    > >
    > > On 05/22/2017 11:25 PM, Luca Urpi wrote:
    > >
    > > Dear OGS developers,
    > >
    > > although OGS5 is at the end of its
    development
    > (or am I
    > > wrong?)
    > > may you update the page
    > >
    >
    https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2
    <https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2>

    >
    <https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2
    <https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2>>

    >
    > >
    >
    <https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2
    <https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2>

    >
    <https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2
    <https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2>>>

    >
    > >
    >
    <https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2
    <https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2>

    >
    <https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2
    <https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2>>

    >
    > >
    >
    <https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2
    <https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2>

    >
    <https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2
    <https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2>>>>

    >
    > >
    > > adding the information that to compile with
    > PETSc not
    > > only the
    > > OGS_CONFIG must be changed, but also the
    > OGS_LSOLVER (see
    > > https://github.com/ufz/ogs5/pull/18
    <https://github.com/ufz/ogs5/pull/18>
    > <https://github.com/ufz/ogs5/pull/18
    <https://github.com/ufz/ogs5/pull/18>>
    > > <https://github.com/ufz/ogs5/pull/18
    <https://github.com/ufz/ogs5/pull/18>
    > <https://github.com/ufz/ogs5/pull/18
    <https://github.com/ufz/ogs5/pull/18>>>
    > > <https://github.com/ufz/ogs5/pull/18
    <https://github.com/ufz/ogs5/pull/18>
    > <https://github.com/ufz/ogs5/pull/18
    <https://github.com/ufz/ogs5/pull/18>>
    > > <https://github.com/ufz/ogs5/pull/18
    <https://github.com/ufz/ogs5/pull/18>
    > <https://github.com/ufz/ogs5/pull/18
    <https://github.com/ufz/ogs5/pull/18>>>> ) ?
    > >
    > > It is a trivial problem. But only after you
    > solve it.
    > >
    > > Another question: what is the latest
    supported
    > version
    > > of PETSc
    > > by OGS 5.7.1?
    > >
    > > Thanks.
    > >
    > > Luca Urpi
    > > +41446338372 <tel:%2B41446338372> <tel:%2B41446338372>
    > >
    > > Swiss Seismological Service
    > > ETH Zürich, NO H 62
    > > Sonneggstrasse 5
    > > 8092 Zürich
    > >
    > > -- You received this message
    because you
    > are
    > > subscribed to the
    > > Google Groups "ogs-devs" group.
    > > To unsubscribe from this group and stop
    receiving
    > > emails from
    > > it, send an email to
    > > ogs-devs+u...@googlegroups.com <javascript:>
    > > <mailto:ogs-devs%2Bunsubscribe@googlegroups.com
    <javascript:>
    > <javascript:>>
    > >
     <mailto:ogs-devs%2Bunsubscribe@googlegroups.com <javascript:>
    > <javascript:>
    > > <mailto:ogs-devs%252Bunsubscribe@googlegroups.com
    <javascript:>
    > <javascript:>>>
    > > <mailto:ogs-devs+u...@googlegroups.com
    > <javascript:>
    > > <mailto:ogs-devs%2Bunsubscribe@googlegroups.com
    <javascript:>
    > <javascript:>>
    > >
     <mailto:ogs-devs%2Bunsubscribe@googlegroups.com <javascript:>
    > <javascript:>
    > > <mailto:ogs-devs%252Bunsubscribe@googlegroups.com
    <javascript:>
    > <javascript:>>>>.
    > > For more options, visit
    > > https://groups.google.com/d/optout
    <https://groups.google.com/d/optout>
    > <https://groups.google.com/d/optout
    <https://groups.google.com/d/optout>>
    > > <https://groups.google.com/d/optout
    <https://groups.google.com/d/optout>
    > <https://groups.google.com/d/optout
    <https://groups.google.com/d/optout>>>
    > > <https://groups.google.com/d/optout
    <https://groups.google.com/d/optout>
    > <https://groups.google.com/d/optout
    <https://groups.google.com/d/optout>>
    > > <https://groups.google.com/d/optout
    <https://groups.google.com/d/optout>
    > <https://groups.google.com/d/optout
    <https://groups.google.com/d/optout>>>>.
    > >
    > > -- You received this message because you are
    > subscribed
    > > to the Google
    > > Groups "ogs-devs" group.
    > > To unsubscribe from this group and stop receiving
    > emails
    > > from it,
    > > send an email to ogs-devs+u...@googlegroups.com
    > <javascript:>
    > > <mailto:ogs-devs%2Bunsubscribe@googlegroups.com
    <javascript:>
    > <javascript:>>
    > >
     <mailto:ogs-devs%2Bunsubscribe@googlegroups.com <javascript:>
    > <javascript:>
    > > <mailto:ogs-devs%252Bunsubscribe@googlegroups.com
    <javascript:>
    > <javascript:>>>.
    > > For more options, visit
    > https://groups.google.com/d/optout
    <https://groups.google.com/d/optout>
    <https://groups.google.com/d/optout
    <https://groups.google.com/d/optout>>
    > > <https://groups.google.com/d/optout
    <https://groups.google.com/d/optout>
    > <https://groups.google.com/d/optout
    <https://groups.google.com/d/optout>>>
    > > <https://groups.google.com/d/optout
    <https://groups.google.com/d/optout>
    > <https://groups.google.com/d/optout
    <https://groups.google.com/d/optout>>
    > > <https://groups.google.com/d/optout
    <https://groups.google.com/d/optout>
    > <https://groups.google.com/d/optout
    <https://groups.google.com/d/optout>>>>.
    > >
    > > --
    > > You received this message because you are
    subscribed to the
    > > Google Groups "ogs-devs" group.
    > > To unsubscribe from this group and stop receiving
    emails
    > from
    > > it, send an email to ogs-devs+u...@googlegroups.com
    > <javascript:>
    > > <mailto:ogs-devs%2Bunsubscribe@googlegroups.com
    <javascript:>
    > <javascript:>>
    > > <mailto:ogs-devs+u...@googlegroups.com <javascript:>
    > > <mailto:ogs-devs%2Bunsubscribe@googlegroups.com
    <javascript:>
    > <javascript:>>>.
    > > For more options, visit
    > https://groups.google.com/d/optout
    <https://groups.google.com/d/optout>
    <https://groups.google.com/d/optout
    <https://groups.google.com/d/optout>>
    > > <https://groups.google.com/d/optout
    <https://groups.google.com/d/optout>
    > <https://groups.google.com/d/optout
    <https://groups.google.com/d/optout>>>.
    > >
    > > --
    > > You received this message because you are subscribed to
    the
    > Google
    > > Groups "ogs-devs" group.
    > > To unsubscribe from this group and stop receiving
    emails from
    > it,
    > > send an email to ogs-devs+u...@googlegroups.com
    <javascript:>
    > > <mailto:ogs-devs%2Bunsubscribe@googlegroups.com
    <javascript:> <javascript:>>.
    > > For more options, visit
    https://groups.google.com/d/optout
    > <https://groups.google.com/d/optout
    <https://groups.google.com/d/optout>>
    > > <https://groups.google.com/d/optout
    <https://groups.google.com/d/optout>
    > <https://groups.google.com/d/optout
    <https://groups.google.com/d/optout>>>.
    > >
    > > --
    > > You received this message because you are subscribed to the
    Google
    > > Groups "ogs-devs" group.
    > > To unsubscribe from this group and stop receiving emails
    from it,
    > send
    > > an email to ogs-devs+u...@googlegroups.com <javascript:>
    > > <mailto:ogs-devs+u...@googlegroups.com <javascript:>>.
    > > For more options, visit https://groups.google.com/d/optout
    <https://groups.google.com/d/optout>
    > <https://groups.google.com/d/optout
    <https://groups.google.com/d/optout>>.
    >
    > --
    > You received this message because you are subscribed to the Google
    > Groups "ogs-devs" group.
    > To unsubscribe from this group and stop receiving emails from it,
    send
    > an email to ogs-devs+u...@googlegroups.com <javascript:>
    > <mailto:ogs-devs+u...@googlegroups.com <javascript:>>.
    > For more options, visit https://groups.google.com/d/optout
    <https://groups.google.com/d/optout>.

--
You received this message because you are subscribed to the Google
Groups "ogs-devs" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to ogs-devs+unsubscribe@googlegroups.com
<mailto:ogs-devs+unsubscribe@googlegroups.com>.
For more options, visit https://groups.google.com/d/optout.

--
渡邉 教弘(工博 Dr.-Ing.)

国立研究開発法人 産業技術総合研究所
再生可能エネルギー研究所(FREA)
再生可能エネルギー研究センター
地熱チーム 研究員

〒963-0298 福島県郡山市待池台二丁目2番9
TEL: 029-861-4463 (内222-44463)
FAX: 024-963-0828
E-MAIL: norihiro.watanabe@aist.go.jp
URL: http://www.aist.go.jp/fukushima/

I tried Wenqing’s script. Didn’t work with my example. Kueper-PcPnw-petsc. However, VTK outputs everything ok. Great work with petsc.

···

On Thursday, June 1, 2017 at 5:51:07 AM UTC+9, Norihiro Watanabe wrote:

I don’t think PVTU output is supported in the official ogs5. you can use
Wenqing’s script

https://github.com/wenqing/post_process_ogs5

On 31.05.17 17:46, Chan-Hee Park wrote:

Thanks, Nori. It works with the new mesh_partition given by WW.

Now, another problem with PVD in the .out file. It doesn’t output
.pvtu files to combine .vtu of each decomposed domain to have a
whole domain. Does this need update Nori?

On Wednesday, May 31, 2017 at 2:54:41 PM UTC+9, Norihiro Watanabe wrote:

Hi,

On 05/31/2017 02:45 PM, Chan-Hee Park wrote:
> Hello Nori,
>
> I have followed your latest patch just merged on CentOS 7. The
> compilation works just fine with the configuration below. However,
when
> I tried it with KueperProblem-PS benchmark, it works great with the
> following.
>
> [nbeyond@cc KueperProblem-PS]$ mpirun -f mfile -np 3 $ogs_petsc
kueper
>
> My question from here is: How can I
> prepare kueper_partitioned_nodes_3.msh,
kueper_partitioned_elems_3.msh,
> and kueper_partitioned_cfg3.msh?  I guess those should come from
>
>     partmesh --ogs2metis kueper
>     mpmetis kueper.mesh
>     partmesh --metis2ogs -np 3 -n kueper
>
>
> I do not see how to get the last one (
*kueper_partitioned_cfg3.msh*). I
> appreciate any help on this.

Have you tested with the latest partmesh available from
[https://github.com/ufz/mesh_partition](https://github.com/ufz/mesh_partition)
<[https://github.com/ufz/mesh_partition](https://github.com/ufz/mesh_partition)>? I think Wenqing has made some
changes and it generates _cfg*.

> One more question, please. Would the latest ogs 5 with the patch work
> with HT problems on sequential mode if the configuration files are
> prepared just as I talked? This is extremely important because it
is all
> about scale-up of applications to multi-million nodes. Thanks in
advance.

What do you mean sequential mode? sequential coupling? HT processes
should also work with petsc.

n

>
> Best regards,
>
>
> On Monday, May 29, 2017 at 7:28:03 AM UTC+9, Norihiro Watanabe wrote:
>
>     many thanks for reporting the details. The problem should be
fixed in
>     #81 ([https://github.com/ufz/ogs5/pull/81](https://github.com/ufz/ogs5/pull/81)
<[https://github.com/ufz/ogs5/pull/81](https://github.com/ufz/ogs5/pull/81)>
>     <[https://github.com/ufz/ogs5/pull/81](https://github.com/ufz/ogs5/pull/81)
<[https://github.com/ufz/ogs5/pull/81](https://github.com/ufz/ogs5/pull/81)>>).
>
>     best,
>     nori
>
>     On 05/26/2017 08:39 PM, Luca Urpi wrote:
>      > Alright, yes the problem is with reusing the build dir.
>      > If cmake is run for the first time, then it sets
OGS_LSOLVER to the
>      > corresponding OGS_CONFIG: if no value is given it defaults
to RF.
>     Then
>      > if the same build folder is used afterwards, with different
>     OGS_CONFIG,
>      > the OGS_LSOLVER needs to be set manually.
>      >
>      > With cmake-gui, OGS_LSOLVER must be set manually, since it
is set
>     to RF
>      > with the first "configure".
>      > However, if OGS_LSOLVER is set manually to DEFAULT, then it is
>     updated
>      > automatically with the right value according to OGS_CONFIG,
running
>      > "configure" for the second time.
>      > Maybe there is an error and OGS_LSOLVER should be set to
DEFAULT
>     by the
>      > first "configure"? I am not very practical with cmake
definitions
>     and
>      > set-up.
>      >
>      > Thanks for your patience.
>      >
>      > Luca
>      >
>      > 2017-05-26 0:11 GMT+02:00 Norihiro Watanabe
>      > <norihiro...@aist.go.jp <javascript:>
>     <mailto:norihiro...@aist.go.jp <javascript:>>>:
>      >
>      >     Hi,
>      >
>      >     sorry there was a typo. it should be -DOGS_CONFIG=PETC. I
>     tested on
>      >     my machine with the following command and it is also
working
>     here.
>      >
>      >     cmake ../sources/ -DOGS_CONFIG=PETSC
>      >     -DPESC_DIR=/opt/petsc/petsc-3.5.4/
-DPETSC_ARCH=gcc-release
>      >
>      >     maybe you need to remove the build dir once and test it
again.
>      >
>      >     n
>      >
>      >
>      >     On 05/24/2017 06:41 PM, Luca Urpi wrote:
>      >
>      >         I tried again, at least on the machine I am using
(Fedora
>     25,
>      >         cmake 3.8.0), it does not set automatically with
cmake or
>     with
>      >         cmake-gui (also, it does not work with MPI).
>      >
>      >
>      >         2017-05-23 23:20 GMT+02:00 Norihiro Watanabe
>      >         <norihiro...@aist.go.jp <javascript:>
>      >         <mailto:norihiro...@aist.go.jp <javascript:>>
>      >         <mailto:norihiro...@aist.go.jp <javascript:>
>      >         <mailto:norihiro...@aist.go.jp <javascript:>>>>:
>      >
>      >              Hi Luca,
>      >
>      >              Setting -DOGS_CONFIG=PESC in CMake should be
enough.
>      >         OGS_LSOLVER is
>      >              automatically set during cmake.
>      >
>      >              Regarding the PETSc version, I think current OGS5
>     supports
>      >         till 3.5.
>      >              (Wenqing, please correct me if I'm wrong).
>      >
>      >
>      >              Best,
>      >              Nori
>      >
>      >
>      >
>      >              On 05/22/2017 11:25 PM, Luca Urpi wrote:
>      >
>      >                  Dear OGS developers,
>      >
>      >                  although OGS5 is at the end of its
development
>     (or am I
>      >         wrong?)
>      >                  may you update the page
>      >
>      >
>
[https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2](https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2)
<[https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2](https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2)>

>
<[https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2](https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2)
<[https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2](https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2)>>

>
>      >
>
<[https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2](https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2)
<[https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2](https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2)>

>
<[https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2](https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2)
<[https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2](https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2)>>>

>
>      >
>      >
>
<[https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2](https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2)
<[https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2](https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2)>

>
<[https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2](https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2)
<[https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2](https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2)>>

>
>      >
>
<[https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2](https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2)
<[https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2](https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2)>

>
<[https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2](https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2)
<[https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2](https://docs.opengeosys.org/docs/devguide5/getting-started/build-configuration#panel3-2)>>>>

>
>      >
>      >                  adding the information that to compile with
>     PETSc not
>      >         only the
>      >                  OGS_CONFIG must be changed, but also the
>     OGS_LSOLVER (see
>      > [https://github.com/ufz/ogs5/pull/18](https://github.com/ufz/ogs5/pull/18)
<[https://github.com/ufz/ogs5/pull/18](https://github.com/ufz/ogs5/pull/18)>
>     <[https://github.com/ufz/ogs5/pull/18](https://github.com/ufz/ogs5/pull/18)
<[https://github.com/ufz/ogs5/pull/18](https://github.com/ufz/ogs5/pull/18)>>
>      >         <[https://github.com/ufz/ogs5/pull/18](https://github.com/ufz/ogs5/pull/18)
<[https://github.com/ufz/ogs5/pull/18](https://github.com/ufz/ogs5/pull/18)>
>     <[https://github.com/ufz/ogs5/pull/18](https://github.com/ufz/ogs5/pull/18)
<[https://github.com/ufz/ogs5/pull/18](https://github.com/ufz/ogs5/pull/18)>>>
>      >                  <[https://github.com/ufz/ogs5/pull/18](https://github.com/ufz/ogs5/pull/18)
<[https://github.com/ufz/ogs5/pull/18](https://github.com/ufz/ogs5/pull/18)>
>     <[https://github.com/ufz/ogs5/pull/18](https://github.com/ufz/ogs5/pull/18)
<[https://github.com/ufz/ogs5/pull/18](https://github.com/ufz/ogs5/pull/18)>>
>      >         <[https://github.com/ufz/ogs5/pull/18](https://github.com/ufz/ogs5/pull/18)
<[https://github.com/ufz/ogs5/pull/18](https://github.com/ufz/ogs5/pull/18)>
>     <[https://github.com/ufz/ogs5/pull/18](https://github.com/ufz/ogs5/pull/18)
<[https://github.com/ufz/ogs5/pull/18](https://github.com/ufz/ogs5/pull/18)>>>> ) ?
>      >
>      >                  It is a trivial problem. But only after you
>     solve it.
>      >
>      >                  Another question: what is the latest
supported
>     version
>      >         of PETSc
>      >                  by OGS 5.7.1?
>      >
>      >                  Thanks.
>      >
>      >                  Luca Urpi
>      >         +41446338372 <tel:%2B41446338372> <tel:%2B41446338372>
>      >
>      >                  Swiss Seismological Service
>      >                  ETH Zürich, NO H 62
>      >                  Sonneggstrasse 5
>      >                  8092 Zürich
>      >
>      >
>      >                  --         You received this message
because you
>     are
>      >         subscribed to the
>      >                  Google Groups "ogs-devs" group.
>      >                  To unsubscribe from this group and stop
receiving
>      >         emails from
>      >                  it, send an email to
>      > ogs-devs+u...@googlegroups.com <javascript:>
>      >         <mailto:ogs-devs%2Bunsubscribe@googlegroups.com
<javascript:>
>     <javascript:>>
>      >
 <mailto:ogs-devs%2Bunsubscribe@googlegroups.com <javascript:>
>     <javascript:>
>      >         <mailto:ogs-devs%252Bunsubscribe@googlegroups.com
<javascript:>
>     <javascript:>>>
>      >                  <mailto:ogs-devs+u...@googlegroups.com
>     <javascript:>
>      >         <mailto:ogs-devs%2Bunsubscribe@googlegroups.com
<javascript:>
>     <javascript:>>
>      >
 <mailto:ogs-devs%2Bunsubscribe@googlegroups.com <javascript:>
>     <javascript:>
>      >         <mailto:ogs-devs%252Bunsubscribe@googlegroups.com
<javascript:>
>     <javascript:>>>>.
>      >                  For more options, visit
>      > [https://groups.google.com/d/optout](https://groups.google.com/d/optout)
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>
>     <[https://groups.google.com/d/optout](https://groups.google.com/d/optout)
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>>
>      >         <[https://groups.google.com/d/optout](https://groups.google.com/d/optout)
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>
>     <[https://groups.google.com/d/optout](https://groups.google.com/d/optout)
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>>>
>      >                  <[https://groups.google.com/d/optout](https://groups.google.com/d/optout)
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>
>     <[https://groups.google.com/d/optout](https://groups.google.com/d/optout)
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>>
>      >         <[https://groups.google.com/d/optout](https://groups.google.com/d/optout)
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>
>     <[https://groups.google.com/d/optout](https://groups.google.com/d/optout)
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>>>>.
>      >
>      >
>      >              --     You received this message because you are
>     subscribed
>      >         to the Google
>      >              Groups "ogs-devs" group.
>      >              To unsubscribe from this group and stop receiving
>     emails
>      >         from it,
>      >              send an email to ogs-devs+u...@googlegroups.com
>     <javascript:>
>      >         <mailto:ogs-devs%2Bunsubscribe@googlegroups.com
<javascript:>
>     <javascript:>>
>      >
 <mailto:ogs-devs%2Bunsubscribe@googlegroups.com <javascript:>
>     <javascript:>
>      >         <mailto:ogs-devs%252Bunsubscribe@googlegroups.com
<javascript:>
>     <javascript:>>>.
>      >              For more options, visit
>     [https://groups.google.com/d/optout](https://groups.google.com/d/optout)
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>>
>      >         <[https://groups.google.com/d/optout](https://groups.google.com/d/optout)
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>
>     <[https://groups.google.com/d/optout](https://groups.google.com/d/optout)
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>>>
>      >              <[https://groups.google.com/d/optout](https://groups.google.com/d/optout)
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>
>     <[https://groups.google.com/d/optout](https://groups.google.com/d/optout)
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>>
>      >         <[https://groups.google.com/d/optout](https://groups.google.com/d/optout)
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>
>     <[https://groups.google.com/d/optout](https://groups.google.com/d/optout)
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>>>>.
>      >
>      >
>      >         --
>      >         You received this message because you are
subscribed to the
>      >         Google Groups "ogs-devs" group.
>      >         To unsubscribe from this group and stop receiving
emails
>     from
>      >         it, send an email to ogs-devs+u...@googlegroups.com
>     <javascript:>
>      >         <mailto:ogs-devs%2Bunsubscribe@googlegroups.com
<javascript:>
>     <javascript:>>
>      >         <mailto:ogs-devs+u...@googlegroups.com <javascript:>
>      >         <mailto:ogs-devs%2Bunsubscribe@googlegroups.com
<javascript:>
>     <javascript:>>>.
>      >         For more options, visit
>     [https://groups.google.com/d/optout](https://groups.google.com/d/optout)
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>>
>      >         <[https://groups.google.com/d/optout](https://groups.google.com/d/optout)
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>
>     <[https://groups.google.com/d/optout](https://groups.google.com/d/optout)
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>>>.
>      >
>      >
>      >     --
>      >     You received this message because you are subscribed to
the
>     Google
>      >     Groups "ogs-devs" group.
>      >     To unsubscribe from this group and stop receiving
emails from
>     it,
>      >     send an email to ogs-devs+u...@googlegroups.com
<javascript:>
>      >     <mailto:ogs-devs%2Bunsubscribe@googlegroups.com
<javascript:> <javascript:>>.
>      >     For more options, visit
[https://groups.google.com/d/optout](https://groups.google.com/d/optout) <[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>
>     <[https://groups.google.com/d/optout](https://groups.google.com/d/optout)
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>>
>      >     <[https://groups.google.com/d/optout](https://groups.google.com/d/optout)
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>
>     <[https://groups.google.com/d/optout](https://groups.google.com/d/optout)
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>>>.
>      >
>      >
>      > --
>      > You received this message because you are subscribed to the
Google
>      > Groups "ogs-devs" group.
>      > To unsubscribe from this group and stop receiving emails
from it,
>     send
>      > an email to ogs-devs+u...@googlegroups.com <javascript:>
>      > <mailto:ogs-devs+u...@googlegroups.com <javascript:>>.
>      > For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout)
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>
>     <[https://groups.google.com/d/optout](https://groups.google.com/d/optout)
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>>.
>
> --
> You received this message because you are subscribed to the Google
> Groups "ogs-devs" group.
> To unsubscribe from this group and stop receiving emails from it,
send
> an email to ogs-devs+u...@googlegroups.com <javascript:>
> <mailto:ogs-devs+u...@googlegroups.com <javascript:>>.
> For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout)
<[https://groups.google.com/d/optout](https://groups.google.com/d/optout)>.


You received this message because you are subscribed to the Google
Groups “ogs-devs” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to ogs-devs+u...@googlegroups.com

mailto:ogs-devs+u...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


渡邉 教弘(工博 Dr.-Ing.)

国立研究開発法人 産業技術総合研究所
再生可能エネルギー研究所(FREA)
再生可能エネルギー研究センター
地熱チーム 研究員

〒963-0298 福島県郡山市待池台二丁目2番9
TEL: 029-861-4463 (内222-44463)
FAX: 024-963-0828

E-MAIL: norihiro…@aist.go.jp

URL: http://www.aist.go.jp/fukushima/