Porosity change result over time for reactive transport in OGS6

Dear All,

I went through the OGS-PHREEQC benchmark and I successfully followed the steps. Now I want to see the porosity change result.
As this benchmark take the initial porosity and permeability then how to get the final porosity and permeability?
Please help me. Thanks in advance.

Md Mahmudul Hassan

Hello Hasan,

I am one of the OGS users. To track down the porosity, you have to activate chemically induced porosity change.


And then use this snippet in the media properties.


Permeability0 is your initial permeability parameter.

Now, I hope your porosity will be reflected in the output files.

However, as far as I know, the current OGS doesn’t output the altered permeability from the KozenyCarman (KC) relation. One way to get the altered permeability is by applying the KC relation with the altered porosity somewhere else (e.g., in MS Excel). But first, you should extract the time series data of porosity from output files.

Hope this solves your issue.


1 Like

Thank you so much Sir. It will help me a lot. I will try to follow your instructions and let you know if I can make it solved.
Have a nice day Sir.

Md Mahmudul Hassan

Dear Sir,

I hope you are doing well. I tried to follow the instruction but unfortunately I couldn’t follow due to my lacking of knowledge. I am a very beginner in the modelling study.
So, please help me by answering some questions:

  1. Where should I put <chemically_induced_porosity_change>true</chemically_induced_porosity_change> line? I tried it in .prj file in the block.

  2. I tried the term “Permeability0” as initial permeability but it doesn’t work. So, should I leave it as the existing term “kappa”?

  3. In output file porosity will be a column?

  4. Does it work with 1D problem or 2D problem or both?

Thank you.

Md Mahmudul Hassan


Regarding the question of where to add


,you can simply include it as follows:


Also, to ensure that you obtain the porosity output over time, follow the procedure below.


Make sure that you haven’t specified anything in the

<!-- No need  to add anything here-->

section under output and

 <!-- No need  to add anything here-->

section under processes.

I expect that you have defined your chemical system in your project file (e.g. prj file)

You can define your problem either in 1D or 2D. In 2D, use <specific_body_force>0 0</specific_body_force> instead of <specific_body_force>0</specific_body_force>.


1 Like