Homepage Books Releases Docs Discourse

Problem with installation of the OGS6 with DataExplorer

Dear, Users

When I download the released ogs6 with utils and execute “DataExplorer”, I have the following problem.

ERROR: In /datadrive/jenkins/workspace/0-EWDG5LJJ55/conan/.conan/data/VTK/7.1.0/bilke/stable/build/b59a343a9b498fdbbd94bc6e0e0b81bdfe2f1509/VTK-7.1.0/Rendering/OpenGL2/vtkShaderProgram.cxx, line 380

vtkShaderProgram (0x2b48bc0): 0:1(10): error: GLSL 1.50 is not supported. Supported versions are: 1.10, 1.20, 1.30, 1.00 ES, and 3.00 ES

``

I think that I have to install the OGS6 from source code at my linux(OS : Ubuntu 14.04) machine with GUI(‘DataExplorer’). Non-gui is well installed on my linux machine. However, when I turn on the cmake with as following :

cmake -L …/ogs \

-DOGS_BUILD_GUI:BOOL=ON \

-DShapelib_INCLUDE_DIR=$SHAPELIB_DIR/include \

-DShapelib_LIBRARY=$SHAPELIB_DIR/lib \

-DCMAKE_INSTALL_PREFIX=$HOME/externalpackage/ogs/install

``

The following ‘make’ error is :

Built target OGSFileConverterLib

In file included from /home/inwoo/externalpackage/ogs/ogs/Applications/DataExplorer/NetCdfDialog/NetCdfConfigureDialog.cpp:10:0:

/home/inwoo/externalpackage/ogs/ogs/Applications/DataExplorer/NetCdfDialog/NetCdfConfigureDialog.h:12:23: fatal error: netcdfcpp.h: No such file or directory

compilation terminated.

In file included from /home/inwoo/externalpackage/ogs/build/Applications/DataExplorer/NetCdfDialog/moc_NetCdfConfigureDialog.cpp:9:0,

             from /home/inwoo/externalpackage/ogs/build/Applications/DataExplorer/NetCdfDialog/NetCdfDialogLib_automoc.cpp:2:

/home/inwoo/externalpackage/ogs/build/Applications/DataExplorer/NetCdfDialog/…/…/…/…/ogs/Applications/DataExplorer/NetCdfDialog/NetCdfConfigureDialog.h:12:23: fatal error: netcdfcpp.h: No such file or directory

compilation terminated.

``

So I add the ‘netcdfcpp.h’ and ‘nvectors.h’ from ‘netcdf-cxx’ folder. But this does not work. I got the following problem.

Building CXX object MeshLib/CMakeFiles/MeshLib.dir/Node.cpp.o

cc1plus: warning: /home/inwoo/externalpackage/ogs/build/MeshLib/cotire/MeshLib_CXX_prefix.hxx.gch: created and used with different settings of -fpic

/home/inwoo/externalpackage/ogs/ogs/Applications/DataExplorer/NetCdfDialog/NetCdfConfigureDialog.cpp: In member function ‘void NetCdfConfigureDialog::createDataObject()’:

/home/inwoo/externalpackage/ogs/ogs/Applications/DataExplorer/NetCdfDialog/NetCdfConfigureDialog.cpp:339:39: error: no matching function for call to ‘get(double*&, long unsigned int*&)’

 _currentVar->get(data_array,length); //create Array of Values

``

I cannot solve this problem.

Best,

Inwoo

Dear Inwoo,

When I download the released ogs6 with utils and execute “DataExplorer”, I
have the following problem.

ERROR: In /datadrive/jenkins/workspace/0-EWDG5LJJ55/conan/.conan/data/VTK/
7.1.0/bilke/stable/build/b59a343a9b498fdbbd94bc6e0e0b81bdfe2f1509/VTK-7.1.0/
Rendering/OpenGL2/vtkShaderProgram.cxx, line 380

vtkShaderProgram (0x2b48bc0): 0:1(10): error: GLSL 1.50 is not supported.
Supported versions are: 1.10, 1.20, 1.30, 1.00 ES, and 3.00 ES

This sounds like your graphic driver does not support the required OpenGL functionality. Please check if you have a decent driver installed. But as you are using an old Linux distribution 14.04 this might be not that easy.

Also if you maybe have a really old graphic card it may not work at all.

I think that I have to install the OGS6 from source code at my linux(OS :
Ubuntu 14.04) machine with GUI('DataExplorer'). Non-gui is well installed
on my linux machine. However, when I turn on the cmake with as following :

cmake -L ../ogs \

   -DOGS_BUILD_GUI:BOOL=ON \

   -DShapelib_INCLUDE_DIR=$SHAPELIB_DIR/include \

   -DShapelib_LIBRARY=$SHAPELIB_DIR/lib \

   -DCMAKE_INSTALL_PREFIX=$HOME/externalpackage/ogs/install

See the developer guide for build instructions. You may want to use the Conan package manager for handling library dependencies:

https://www.opengeosys.org/docs/devguide/getting-started/build-configuration/#install-required-libraries-with-conan

···

On 17 Aug 2018, at 8:02, Inwoo wrote:

The following ‘make’ error is :

Built target OGSFileConverterLib

In file included from /home/inwoo/externalpackage/ogs/ogs/Applications/
DataExplorer/NetCdfDialog/NetCdfConfigureDialog.cpp:10:0:

/home/inwoo/externalpackage/ogs/ogs/Applications/DataExplorer/NetCdfDialog/
NetCdfConfigureDialog.h:12:23: fatal error: netcdfcpp.h: No such file or
directory

compilation terminated.

In file included from /home/inwoo/externalpackage/ogs/build/Applications/
DataExplorer/NetCdfDialog/moc_NetCdfConfigureDialog.cpp:9:0,

                 from /home/inwoo/externalpackage/ogs/build/Applications/
DataExplorer/NetCdfDialog/NetCdfDialogLib_automoc.cpp:2:

/home/inwoo/externalpackage/ogs/build/Applications/DataExplorer/NetCdfDialog
/../../../../ogs/Applications/DataExplorer/NetCdfDialog/
NetCdfConfigureDialog.h:12:23: fatal error: netcdfcpp.h: No such file or
directory

compilation terminated.

So *I add the ‘netcdfcpp.h’ and ‘nvectors.h’ from ‘netcdf-cxx’ *folder. But
this does not work. I got the following problem.

Building CXX object MeshLib/CMakeFiles/MeshLib.dir/Node.cpp.o

cc1plus: warning: /home/inwoo/externalpackage/ogs/build/MeshLib/cotire/
MeshLib_CXX_prefix.hxx.gch: created and used with different settings of -fpic

/home/inwoo/externalpackage/ogs/ogs/Applications/DataExplorer/NetCdfDialog/
NetCdfConfigureDialog.cpp: In member function ‘void NetCdfConfigureDialog::
createDataObject()’:

/home/inwoo/externalpackage/ogs/ogs/Applications/DataExplorer/NetCdfDialog/
NetCdfConfigureDialog.cpp:339:39: error: no matching function for call to ‘
get(double*&, long unsigned int*&)’

     _currentVar->get(data_array,length); //create Array of Values

I cannot solve this problem.

Best,

Inwoo

--
You received this message because you are subscribed to the Google Groups "ogs-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ogs-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Dear Bilke,

I read your comments and install the ogs with conan usage. I works good.

When I used the “conan”, I got the problem with “sudo apt-get update”. Because my ‘update-manger’ has the corrupted ppa(personal package archive’, and it made a trouble. So I fixed it now, and installation of ogs with conan usage works good.

Thank you

Best regards

Inwoo